Guess which web browser I’m using right now!

I’ll give you a hint: NOT Chrome.

Here’s the deal. I used to use Firefox for everything. I loved it. In comparison to IE, it was like a dream come true. I had addons and little gadgets and all kinds of things set up just the way I liked it. When Chrome came along, I tried it, but didn’t like that (at least at first) I couldn’t bring along all of my little buttons and widgets and whatever.

But when I started to notice how much faster Chrome loaded webpages, I started to think that maybe I didn’t need all of those little bells and whistles. So I made the switch.

And I loved it. I love the sleek design. I love the speed. I love that it’s integrated with my Google account, and that bookmarks and everything else syncs between my various devices with virtually no effort from me. I love that I use far fewer extensions/add-ons than I once did. I love the way the “Omni Bar” (address/search) works.  So I had been using Chrome ever since… until now.

The thing is… as much as I love Chrome, I kind of love Facebook more. And for the past month or so, Chrome has started to HATE Facebook.

Virtually every time I open Facebook for the first time in a particular browsing session, it freezes the tab, and sometimes the whole browser. It seems to get snagged when it’s trying to load the chat list. But more recently I noticed it freezes when I try to alter the privacy of a particular post, too. Loading the page for Dan’s Discoveries is a sort of hit or miss exercise, and sometimes it loads but won’t actually work to post anything.

It seems like others have similar problems, but so far there’s no resolution. I kept hoping that Chrome would receive an update–I even uninstalled it and did a fresh installation. I’ve tried disabling the built-in Flash, and a few other things, but nothing seems to work…

These might seem like little issues, but when they happen on a regular basis, it gets frustrating. And today, when I attempted to alter the privacy settings on a rather long post I’d written… I lost the post, because the page became unresponsive.

So here I am on Firefox again. And as great as Firefox is… I would much rather use Chrome.

So if anyone has any suggestions on how to get it to work well again, that’d be swell! Better yet, if any of you work at Google, please feel free to just send out a fix. I’ll be watching for it!

Tagged with:
 
1 comments